Home US Technical Support

Can't get back to game!

Ok Wth...I got "lost connection to server" error message. Game auto-refreshed, NOW I HAVE A BLACK SCREEN!!!! I tried to manually refresh but still the Black Screen. And yes, @CM Popeye I cleared my cache, even tried to rebooting laptop, and another browser.


  • what is going on with the game it want let me get on the site all I get is a black page
  • fab1960 (US1)fab1960 (US1) Member Posts: 16
    Same problems !
    Just when i make an offensive message on forum ;-).
    Wait for resolution !

  • Parcival (US1)Parcival (US1) Member Posts: 1
    My alliance and several of our coalition are having the same problem.
  • MorganaLeFey (US1)MorganaLeFey (US1) Member Posts: 36
    SERIOUSLY?? In the MIDDLE of a war and you cut us off -  bet the other guys are online - get your Shit TOGETHER Ghastly Games!!
  • flyingpig (US1)flyingpig (US1) Member Posts: 50
    † You've been eaten by a Dragon †
  • Lepew (US1)Lepew (US1) Member Posts: 25
    edited 17.08.2016
    me too. probably will be down till tomorrow since they have only 1 shift working and no one is there to restart the server.

    lol flyingpig.
  • I also was in the middle of an attack and cant get back on I would like to get back on and recall my heros before I lose all my troops
  • Lady Adriel (US1)Lady Adriel (US1) Member Posts: 7
    I can not get into the game either, a black screen....think the last dragon ate me...my troops will all die of hunger within 8 hrs from the free higher level troops I just got  unless someone attacked me while I am in limbo...
  • RAIL ROAD (US1)RAIL ROAD (US1) Member Posts: 23
  • it is back on don't know for how long
  • kapn_jack (US1)kapn_jack (US1) Member Posts: 62
    @CM Popeye ..c'mon Popeye ..say again that its "only a small percentage having the problem" ..what u cant "DUPLICATE" the issue? ..all u gotta do is PLAY THE EFN GAME & IT WILL HAPPEN!!!!
  • sskrout (US1)sskrout (US1) Member Posts: 12
    I, too, am still having issues. Ever since the screen went black the other day, I can't get back into game. It continually "loads game assets" but never progresses. I have tried everything, even scanning my computer, resetting modem, restoring computer... no resolution.
  • CM PopeyeCM Popeye Community Manager Posts: 1,308
    We are still not sure what is causing the problem. I can tell you that all of us here play it, and the performance is fine. I actually play on the US server, and never really have any issues. This is why it has been so tough for the team to diagnose what might be going on with certain accounts. I will talk to the team to see if we can arrange some off site tests to get to the bottom of the cases for these login issues.

  • sskrout (US1)sskrout (US1) Member Posts: 12
    I am on the us server as well. Thank you
  • Miss Yoda (US1)Miss Yoda (US1) Member Posts: 10
    My daughter, Fairyrose, had the game crash on her a few hours ago.  She did the cookie/cache clearing, and now, when she attempts to log in (U.S. server), she gets a message that her password has "invalid characters."  She has neither changed nor shared her password, and has not yet received a reply from support.  What gives with all of these errors and crashes?
  • CatBooklady (US1)CatBooklady (US1) Member Posts: 75
    @cm popeye  I bet we burnt your castle once or twice at US server. that's why u guys increased the training time and removed the burning :P :P :P
    Never thought of this @Getos (US1) ;) May be that's the answer!

    Chuckling...thanks for the laugh.
  • sskrout (US1)sskrout (US1) Member Posts: 12
    Has any progress been made as to why I can't get beyond loading assets to actually play? if I have to, I would be willing to start all over with a new account to play with my alliance.
  • CatBooklady (US1)CatBooklady (US1) Member Posts: 75
    Has any progress been made as to why I can't get beyond loading assets to actually play? if I have to, I would be willing to start all over with a new account to play with my alliance.
    It's up @sskrout (US1)  Just let it load. Takes a little time, but it finally loads if cache and cookies are cleared. A bit annoying too.
  • sskrout (US1)sskrout (US1) Member Posts: 12
    I keep trying... I leave and read a book or do dishes, sometimes for an hour or more. I will continue thank you. Yes all cookies and caches have been cleared.
Sign In to comment.